$re = '/([а-яА-Яa-zA-Z])[а-яА-Яa-zA-Z]* ([а-яА-Яa-zA-Z])[а-яА-Яa-zA-Z]* ([а-яА-Яa-zA-Z])[а-яА-Яa-zA-Z]*/m';
$str = 'ИВАН ИВАНОВ ИВАНОВИЧ';
$subst = "$1 $2 $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;