re = /([а-яА-Яa-zA-Z])[а-яА-Яa-zA-Z]* ([а-яА-Яa-zA-Z])[а-яА-Яa-zA-Z]* ([а-яА-Яa-zA-Z])[а-яА-Яa-zA-Z]*/m
str = 'ИВАН ИВАНОВ ИВАНОВИЧ'
subst = '$1 $2 $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result