const regex = new RegExp('[\\w]{16}.[\\w]{44}$', 'gm')
const str = `### Do not type in the full URL (e.g. "sub.example.com/blahblah")
### Use the path only, starting with the first slash
### - Pranav Mishra
# Generic API
## Regex: ^/api([/?].*)?\$
/api?some_random_api_code_here
# Health Check
## Regex: ^/healthz.*\$
/healthz/1
# PrivateBin test
## Regex: [\\w]{16}#[\\w]{44}\$
/?6264cc7c26fd522b#6LgXAArG8BYwFsCnFY8QG7w65bfh3fvTAbx9T9aE3jG3
/?7b01a9919ac887ba#FdvmDkrcGX2F6Gvc1tq15xEaaLzMMBoPj6AZVsGPL9VP
/?c6e27eda79460e19#2vGuJsfKvKr1U2vAtDPHAoCJxXZ2jXj8QtX3GPovMr4M
/?b70ec2de34888ae8#Dz1PRy9raeFFaTCu3453gz9tqWBu1YCMkYkuUuy2f93M
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}