import re
regex = re.compile(r"[\w]{16}.[\w]{44}$", flags=re.MULTILINE)
test_str = ("### Do not type in the full URL (e.g. \"sub.example.com/blahblah\")\n"
"### Use the path only, starting with the first slash\n"
"### - Pranav Mishra\n\n"
"# Generic API\n"
"## Regex: ^/api([/?].*)?$\n"
"/api?some_random_api_code_here\n\n"
"# Health Check\n"
"## Regex: ^/healthz.*$\n"
"/healthz/1\n\n"
"# PrivateBin test\n"
"## Regex: [\\w]{16}#[\\w]{44}$\n"
"/?6264cc7c26fd522b#6LgXAArG8BYwFsCnFY8QG7w65bfh3fvTAbx9T9aE3jG3\n"
"/?7b01a9919ac887ba#FdvmDkrcGX2F6Gvc1tq15xEaaLzMMBoPj6AZVsGPL9VP\n"
"/?c6e27eda79460e19#2vGuJsfKvKr1U2vAtDPHAoCJxXZ2jXj8QtX3GPovMr4M\n"
"/?b70ec2de34888ae8#Dz1PRy9raeFFaTCu3453gz9tqWBu1YCMkYkuUuy2f93M\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")