using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[KJ0-9]*F[KJ0-9]*N[KJ0-9]*|[KJ0-9]*N[KJ0-9]*F[KJ0-9]*";
string input = @"FKJJJJN456
KJFN012
NFKJ12
012FNKJ
123FKJJJN";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}