$re = '/[KJ0-9]*F[KJ0-9]*N[KJ0-9]*|[KJ0-9]*N[KJ0-9]*F[KJ0-9]*/m';
$str = 'FKJJJJN456
KJFN012
NFKJ12
012FNKJ
123FKJJJN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);