import re
regex = re.compile(r"[KJ0-9]*F[KJ0-9]*N[KJ0-9]*|[KJ0-9]*N[KJ0-9]*F[KJ0-9]*", flags=re.MULTILINE)
test_str = ("FKJJJJN456\n"
"KJFN012 \n"
"NFKJ12\n"
"012FNKJ\n"
"123FKJJJN")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")