using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"DL_CaseState[^a-zA-Z0-9_]*[\w]+[^a-zA-Z0-9_]*(?!(and|or))";
string input = @"set = 1 and DL_Casestate='0'";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}