const regex = /DL_CaseState[^a-zA-Z0-9_]*[\w]+[^a-zA-Z0-9_]*(?!(and|or))/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('DL_CaseState[^a-zA-Z0-9_]*[\\w]+[^a-zA-Z0-9_]*(?!(and|or))', 'i')
const str = `set = 1 and DL_Casestate='0'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}