import re
regex = re.compile(r"DL_CaseState[^a-zA-Z0-9_]*[\w]+[^a-zA-Z0-9_]*(?!(and|or))", flags=re.IGNORECASE)
test_str = "set = 1 and DL_Casestate='0'"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")