#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bAB([^C,.\s][^,.\s]+)"
Local $sString = "ABC123-xyz" & @CRLF & _
"ABC123def" & @CRLF & _
"AB123xY-z" & @CRLF & _
"AB123deF" & @CRLF & _
"ABr1235"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")