package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bAB([^C,.\s][^,.\s]+)`)
var str = `ABC123-xyz
ABC123def
AB123xY-z
AB123deF
ABr1235`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}