$re = '/\bAB([^C,.\s][^,.\s]+)/m';
$str = 'ABC123-xyz
ABC123def
AB123xY-z
AB123deF
ABr1235';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);