$re = '/(<b md(?!<|>).+>|<b \S+ md>|<b md>|<b .+ md .+>)(.+)(<\/b>)/mU';
$str = '<b sdsd md sdsdds>a</b>
<b>adsa</b>
<b md>a</b>
<b md>sdasdas</b>
<b md class ="sd">aaa</b> <b md>aaa</b> <b md>a</b>
<b ac md>a</b>**DENEME** **DENEME**
<b md>sd <b md>sd</b></b>
<b md>(boş olmasın)</b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);