re = /(<b md(?!<|>).+>|<b \S+ md>|<b md>|<b .+ md .+>)(.+)(<\/b>)/m
str = '<b sdsd md sdsdds>a</b>
<b>adsa</b>
<b md>a</b>
<b md>sdasdas</b>
<b md class ="sd">aaa</b> <b md>aaa</b> <b md>a</b>
<b ac md>a</b>**DENEME** **DENEME**
<b md>sd <b md>sd</b></b>
<b md>(boş olmasın)</b>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end