# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<b md(?!<|>).+>|<b \S+ md>|<b md>|<b .+ md .+>)(.+)(<\/b>)"
test_str = ("<b sdsd md sdsdds>a</b> \n"
"<b>adsa</b>\n"
"<b md>a</b>\n"
"<b md>sdasdas</b>\n"
"<b md class =\"sd\">aaa</b> <b md>aaa</b> <b md>a</b>\n"
"<b ac md>a</b>**DENEME** **DENEME**\n\n"
"<b md>sd <b md>sd</b></b>\n\n"
"<b md>(boş olmasın)</b>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.