package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(как_.*?),`)
var str = `привет,как_твои_дела,дела, хорошо
привет,как_твои_дела,
привет,как_твои_дела
как_твои_дела`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}