$re = '/(как_.*?),/m';
$str = 'привет,как_твои_дела,дела, хорошо
привет,как_твои_дела,
привет,как_твои_дела
как_твои_дела';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);