const regex = /(как_.*?),/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(как_.*?),', 'gm')
const str = `привет,как_твои_дела,дела, хорошо
привет,как_твои_дела,
привет,как_твои_дела
как_твои_дела`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}