import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=src=\").*(?=\")";
final String string = "src=\"/sites/default/files/resize/m14/4m213/3567705_images_12175409452-.jpg\"\n"
+ "src=\"/sites/default/files/resize/afaf/5814f65f91ef731c793433fe5096e892-.jpg\"\n"
+ "src=\"/sites/default/files/resize/test/640m-.jpg\"\n"
+ "src=\"/sites/default/files/resize/5173.970-.jpg\"\n"
+ "src=\"/sites/default/files/resize/a/b/3/5main_br_xl-.jpg\"\n"
+ "src=\"/sites/default/files/resize/images/m8/image8-.jpg\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}