$re = '/(?<=src=").*(?=")/m';
$str = 'src="/sites/default/files/resize/m14/4m213/3567705_images_12175409452-.jpg"
src="/sites/default/files/resize/afaf/5814f65f91ef731c793433fe5096e892-.jpg"
src="/sites/default/files/resize/test/640m-.jpg"
src="/sites/default/files/resize/5173.970-.jpg"
src="/sites/default/files/resize/a/b/3/5main_br_xl-.jpg"
src="/sites/default/files/resize/images/m8/image8-.jpg"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);