const regex = /(?<=src=").*(?=")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=src=").*(?=")', 'gm')
const str = `src="/sites/default/files/resize/m14/4m213/3567705_images_12175409452-.jpg"
src="/sites/default/files/resize/afaf/5814f65f91ef731c793433fe5096e892-.jpg"
src="/sites/default/files/resize/test/640m-.jpg"
src="/sites/default/files/resize/5173.970-.jpg"
src="/sites/default/files/resize/a/b/3/5main_br_xl-.jpg"
src="/sites/default/files/resize/images/m8/image8-.jpg"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}