using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"watch\?v=(?<code>[A-Za-z0-9\_]*)[\/|""]";
string input = @"https://www.youtube.com/watch?v=dQw4w9WgXcQ|https://www.youtube.com/watch?v=wZZ7oFKsKzY";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}