$re = '/watch\?v=(?<code>[A-Za-z0-9\_]*)[\/|"]/';
$str = 'https://www.youtube.com/watch?v=dQw4w9WgXcQ|https://www.youtube.com/watch?v=wZZ7oFKsKzY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);