const regex = /watch\?v=(?<code>[A-Za-z0-9\_]*)[\/|"]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('watch\\?v=(?<code>[A-Za-z0-9\\_]*)[\\\/|"]', 'g')
const str = `https://www.youtube.com/watch?v=dQw4w9WgXcQ|https://www.youtube.com/watch?v=wZZ7oFKsKzY`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}