use strict;
my $str = 'uerhfieruhfi eqrhf\'dq f
apsokd f
aspokd f
apsodkf
asokdf
ok23 p
4ok23
p4ok23 p
4ko12 p3o4koerg sdf9gi sdfig sdfgi s
dfgo
sdf[pg
sd[ pfgo sd
[pgfo [
gop g[eprg
wrpgo ';
my $regex = qr/^.{6}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}