import Foundation
let pattern = #"^.{6}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
uerhfieruhfi eqrhf'dq f
apsokd f
aspokd f
apsodkf
asokdf
ok23 p
4ok23
p4ok23 p
4ko12 p3o4koerg sdf9gi sdfig sdfgi s
dfgo
sdf[pg
sd[ pfgo sd
[pgfo [
gop g[eprg
wrpgo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)