import re
regex = re.compile(r"\b(?!\d(\d)\1)[01]+\b", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("0101010, 1010101010\n"
"1\n"
"1111000")
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)