package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?xm)
\b #boundary - begining of text
\w[^\d]+? #words without number(s) and ungreedy (?)
\b #boundary - end of text`)
var str = `abc
123
123anb
abc123
ba3
my age is 15
current year is 1980
$#%&#@#$%@!$$
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}