const regex = /(?xm)
\b #boundary - begining of text
\w[^\d]+? #words without number(s) and ungreedy (?)
\b #boundary - end of text/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?xm)
\\b #boundary - begining of text
\\w[^\\d]+? #words without number(s) and ungreedy (?)
\\b #boundary - end of text', 'gm')
const str = `abc
123
123anb
abc123
ba3
my age is 15
current year is 1980
\$#%&#@#\$%@!\$\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}