$re = '/(?xm)
\b #boundary - begining of text
\w[^\d]+? #words without number(s) and ungreedy (?)
\b #boundary - end of text/m';
$str = 'abc
123
123anb
abc123
ba3
my age is 15
current year is 1980
$#%&#@#$%@!$$
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);