using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",.*,\d";
string input = @"a,b,c,123,def,ghi,jkl,mno,pqr,stu,vxw,yz";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}