$re = '/,.*,\d/';
$str = 'a,b,c,123,def,ghi,jkl,mno,pqr,stu,vxw,yz';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);