const regex = /.where\(.*?\)\.(first|last|single)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.where\\(.*?\\)\\.(first|last|single)', 'gm')
const str = `a.where().last()
a.where(dsad).first(aaa)
a.where(fff).sort().last()
a.where(bb).ok().bad().first()`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}