$re = '/.where\(.*?\)\.(first|last|single)/m';
$str = 'a.where().last()
a.where(dsad).first(aaa)
a.where(fff).sort().last()
a.where(bb).ok().bad().first()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);