re = /.where\(.*?\)\.(first|last|single)/m
str = 'a.where().last()
a.where(dsad).first(aaa)
a.where(fff).sort().last()
a.where(bb).ok().bad().first()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end