import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<inverted>!)?\\s*(?<name>--?\\w[\\w-]*)\\s*(?<values>(?:\\s*(?:\\w\\S+|[\"'](?:[^\"'\\\\]*(?:\\\\.[^\"'\\\\]*)*)['\"]))*)\\K";
final String string = "-a val1 ! -b value-with-dash --custom \"string with crazy -a --test stuff inside\" --param-with-dash val1 val2 -c ! -d ! --test -t -g";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}