re = /(?<inverted>!)?\s*(?<name>--?\w[\w-]*)\s*(?<values>(?:\s*(?:\w\S+|["'](?:[^"'\\]*(?:\\.[^"'\\]*)*)['"]))*)\K/
str = '-a val1 ! -b value-with-dash --custom "string with crazy -a --test stuff inside" --param-with-dash val1 val2 -c ! -d ! --test -t -g'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end