$re = '/(?<inverted>!)?\s*(?<name>--?\w[\w-]*)\s*(?<values>(?:\s*(?:\w\S+|["\'](?:[^"\'\\\\]*(?:\\\\.[^"\'\\\\]*)*)[\'"]))*)\K/';
$str = '-a val1 ! -b value-with-dash --custom "string with crazy -a --test stuff inside" --param-with-dash val1 val2 -c ! -d ! --test -t -g';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);