#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sx)\[(run)] ( (?: (?: (?!\[/?\1]) . )* | (?R) )* ) \[/\1]"
Local $sString = "[run][one]This[/one][two]That[/two][/run]" & @CRLF & _
"[run][one]This 2[/one][two]That 2[/two][/run]" & @CRLF & _
"[run][one]IF THIS RESULT DO THIS [run][one]This[/one][two]That[/two][/run][/one][two]IF THIS RESULT DO THAT [run][one]This[/one][two]That[/two][/run][/two][/run]" & @CRLF & _
"" & @CRLF & _
"[run][one]IF THIS RESULT DO THIS " & @CRLF & _
"[run][one]This[/one][two]That[/two][/run]" & @CRLF & _
"[/one][two]IF THIS RESULT DO THAT [run][one]This[/one][two]That[/two][/run][/two][/run]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")