import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(run)] ( (?: (?: (?!\\[/?\\1]) . )* | (?R) )* ) \\[/\\1]";
final String string = "[run][one]This[/one][two]That[/two][/run]\n"
+ "[run][one]This 2[/one][two]That 2[/two][/run]\n"
+ "[run][one]IF THIS RESULT DO THIS [run][one]This[/one][two]That[/two][/run][/one][two]IF THIS RESULT DO THAT [run][one]This[/one][two]That[/two][/run][/two][/run]\n\n"
+ "[run][one]IF THIS RESULT DO THIS \n"
+ "[run][one]This[/one][two]That[/two][/run]\n"
+ "[/one][two]IF THIS RESULT DO THAT [run][one]This[/one][two]That[/two][/run][/two][/run]";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}