$re = '~\[(run)] ( (?: (?: (?!\[/?\1]) . )* | (?R) )* ) \[/\1]~sx';
$str = '[run][one]This[/one][two]That[/two][/run]
[run][one]This 2[/one][two]That 2[/two][/run]
[run][one]IF THIS RESULT DO THIS [run][one]This[/one][two]That[/two][/run][/one][two]IF THIS RESULT DO THAT [run][one]This[/one][two]That[/two][/run][/two][/run]
[run][one]IF THIS RESULT DO THIS
[run][one]This[/one][two]That[/two][/run]
[/one][two]IF THIS RESULT DO THAT [run][one]This[/one][two]That[/two][/run][/two][/run]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);