using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SELECT (.*) (?:INTO (.*)).*\sFROM (.*)(?:\sWHERE (.*)).*(?:\sHAVING (.*)).*(?:\sORDER BY (.*)).*";
string input = @"SELECT test1.col1, test1.col2, test1.col3, ""aaa"" AS Error, x as y INTO test2
FROM test1, test3
WHERE (((test1.col2)=""bbb"") AND ((test1.col3) Is Null Or (test1.col3)=""ccc""))
HAVING 1=1
ORDER BY 1;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}