import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SELECT (.*) (?:INTO (.*)).*\\sFROM (.*)(?:\\sWHERE (.*)).*(?:\\sHAVING (.*)).*(?:\\sORDER BY (.*)).*";
final String string = "SELECT test1.col1, test1.col2, test1.col3, \"aaa\" AS Error, x as y INTO test2\n"
+ "FROM test1, test3\n"
+ "WHERE (((test1.col2)=\"bbb\") AND ((test1.col3) Is Null Or (test1.col3)=\"ccc\"))\n"
+ "HAVING 1=1\n"
+ "ORDER BY 1;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}