const regex = /SELECT (.*) (?:INTO (.*)).*\sFROM (.*)(?:\sWHERE (.*)).*(?:\sHAVING (.*)).*(?:\sORDER BY (.*)).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('SELECT (.*) (?:INTO (.*)).*\\sFROM (.*)(?:\\sWHERE (.*)).*(?:\\sHAVING (.*)).*(?:\\sORDER BY (.*)).*', 'gm')
const str = `SELECT test1.col1, test1.col2, test1.col3, "aaa" AS Error, x as y INTO test2
FROM test1, test3
WHERE (((test1.col2)="bbb") AND ((test1.col3) Is Null Or (test1.col3)="ccc"))
HAVING 1=1
ORDER BY 1;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}