const regex = /^(?=\d{9}$)\d*(\d)(\d)(?:\1\2){3}\d*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\d{9}$)\\d*(\\d)(\\d)(?:\\1\\2){3}\\d*$', 'gm')
const str = `561616161
561616162
123456789
61616161`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}