re = /^(?=\d{9}$)\d*(\d)(\d)(?:\1\2){3}\d*$/m
str = '561616161
561616162
123456789
61616161'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end