$re = '/^(?=\d{9}$)\d*(\d)(\d)(?:\1\2){3}\d*$/m';
$str = '561616161
561616162
123456789
61616161';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);