using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{1,2}\/\d{1,2}\/(\d{4}|\d{2})\b";
string input = @"Bắt các chuỗi ngày tháng này
12/01/2017
15/2/2017
3/03/2018
1/1/2018
7/9/18
60/60/2018
Không bắt các chuỗi như thế này, vì không đúng ngày tháng
123/2/1234 13/ab/3346 12/223/12
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}