package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d{1,2}\/\d{1,2}\/(\d{4}|\d{2})\b`)
var str = `Bắt các chuỗi ngày tháng này
12/01/2017
15/2/2017
3/03/2018
1/1/2018
7/9/18
60/60/2018
Không bắt các chuỗi như thế này, vì không đúng ngày tháng
123/2/1234 13/ab/3346 12/223/12
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}